Issues with Account and Booking Emails

Incident Report for Clearhead

Resolved

A fix has been deployed and emails are working correctly again. There are a number of emails that are still backlogged and will be processed over the next day.
Posted Sep 01, 2025 - 11:27 UTC

Investigating

We are currently investigating an issue where account related emails are not being sent to all users.
Posted Sep 01, 2025 - 02:11 UTC
This incident affected: Provider Portal, Wellbeing Portal, and Appointment Processing.